5 1 1 1 1 1 1 1 1 1 1 Рейтинг 5.00 [5 Голоса (ов)]

Логотип к статье почему нужно переводить Joomla! проекты с PHP5.2.x на PHP5.3.x или PHP5.4.x

PHP 5.2 это мертвый релиз, поддержка которого, как и его финальной версии, - PHP 5.2.17 закончена еще 6 января 2011 года.

Если Вы используете эти релизы, - настоятельно рекомендуется произвести обновление до текущей версии так, как использование старых версий может подвергнуть Ваш Joomla проект уязвимостям и ошибкам, исправленным в более поздних версиях PHP. Как определить письмо с вирусом УЗНАЙ в блоге Yznaj.com.

При использовании PHP 5.2, веб-ресурсы подвержены известным угрозам безопасности, которые используются для атаки веб-сайтов. Характер этих атак таков, что брандмауэр сервера и / или компонент безопасности, не может защитить ваш сайт. Если вы используете PHP 5.2 ваш сайт будет взломан. Таким образом, использование PHP 5.2, является брешью в системе безопасности сайтов.

Вдобавок к этому, в PHP 5.2 не хватает некоторых функций, необходимых для разработки современного программного обеспечения с простым и понятным интерфейсом [ дружественный юзабилити (Прим. Автора)].

PHP 5.2 медленный. Очень медленный. Как показали тесты, PHP 5.2 в шесть-семь раз (600% - 700%) медленнее, чем PHP 5.3 на том же оборудовании. И это не шутка! Например, резервное копирование происходит за 2 минуты 23 секунд на PHP 5.2 и всего 31 секунду на PHP 5.3. Тот же ресурс, одинаковая конфигурация, то же оборудование.

Испытания производились 5 раз, а результат такой же, с точностью до секунды. Это огромная разница в скорости. Поисковые системы ранжируют быстрые сайты в первую очередь, а использование PHP 5.2 негативно отразится на рейтинге Вашего ресурса в поисковых системах.

Что можно сделать, если хостинг все еще работает на устаревшей PHP 5.2?

Существуют хостинги, которые по-прежнему предлагают PHP 5.2 по умолчанию, а поддержку PHP 5.3 или 5.4, - предлагают в качестве опции. Вы можете узнать у хостинг-провайдера, как правильно перейти на PHP 5.3. Joomla! 2,5 и все ее расширения поддерживают PHP 5.3. Joomla! 3.0 и выше требует PHP не ниже 5.3.1, Вы не сможете использовать ее на более старых версиях PHP.

ВАЖНО: Некоторые провайдеры утверждают, что как единственную альтернативу PHP 5.2, могут предложить только PHP 6. Не используйте ее! PHP 6 должна была быть следующим релизом, после PHP 5.2, но ее развитие было приостановлено и вместо нее вышел PHP 5.3. PHP 6 альфа - нестабильное программное обеспечение, которое нарушит целостность вашего сайта.

Хуже того, есть еще компании, которые не могут предоставить возможность использования PHP 5.3 или более поздней. Такие хосты следует избегать любой ценой. Это означает, что хостинг компания не заботится об затрате минимального количество времени, необходимого для правильной установки их машин и обеспечения Вашей безопасности. Вы действительно хотите доверить им свой сайт? Если вы застряли на таком хостинге, - настоятельно рекомендуется переход к достойной хостинговой компании.

Разработано для Disqus