5 1 1 1 1 1 1 1 1 1 1 Рейтинг 5.00 [1 Голос]

Совместимо с Джумла 3.4.xСовместимо с Джумла 3.5.xСовместимо с Джумла 3.6.xСовместимо с Джумла 3.7.xСовместимо с Джумла 3.8.xСовместимо с Джумла 3.9.xСовместимо с Джумла 4.xСовместимо с PHP линейки 5.4.xСовместимо с PHP линейки 5.5.xСовместимо с PHP линейки 5.6.xСовместимо с PHP линейки 7.0.xСовместимо с PHP линейки 7.1.xСовместимо с PHP линейки 7.2.xиконка компонента Joomlaиконка русской локализациииконка украинского языкаlogo english localisation

Логотип компонента Akeeba Backup ANGIE

Недавно, 22 мая 2018 года, вышел релиз Akeeba Backup - версия 6.1.0, добавляющий поддержку Joomla 4.0.0 Alpha 2 и PHP седьмой линейки (также и PHP 7.2), а также решающий известные проблемы и добавляющий некоторые новые функции. Команда JoomlaMaster, кроме стандартного - английского, добавила поддержку украинского (отсутствует полная украинская локализация даже на сайте разработчика) и русского языков, проверена стабильность работы расширения и локализаций.

Примечания к выпуску

Что нового

  1. Автоматическое определение отсутствия FOF или FEF. В маловероятном случае, когда эти две необходимые библиотеки не были автоматически установлены, когда вы установили пакет расширения, или вы их случайно отключили / удалили, программное обеспечение теперь сможет обнаружить условие этой ошибки и предоставит вам полезную информацию для его устранения. Ранее, просто был сбой с кодом ошибки PHP, который был не очень полезен для не-разработчиков.
  2. Алфавитная сортировка архивов на странице Обнаружения. Когда вы импортируете архивы резервных копий с помощью страницы Обнаружения, они теперь будут отсортированы в алфавитном порядке. Если вы используете шаблон именования резервных копий, аналогичный тому, который используется по умолчанию, это означает, что ваши резервные копии будут, более или менее, организованы к моменту их принятия, поэтому вам будет проще найти правильный файл для импорта.
  3. Мастер переноса сайта не будет работать в Firefox. Проблема существует в Firefox Quantum (версия 57 и более поздние версии). Побочный эффект того, как Firefox обрабатывает кнопку с обработчиком onClick, который не возвращает значение false или отменяет событие клика, приведет к тому, что основная страница компонента будет показана после нажатия кнопки, чтобы проверить правильность URL-адреса целевого сайта. Эта функция работает без проблем в других браузерах, таких как Chrome и Opera.

Исправление ошибок

  • Joomla! 3.4 или более поздняя версия. Поддерживается только Joomla! 3.4 или новее, включая 3.5, 3.6, 3.7 и 3.8. Настоятельно рекомендуется использовать последнюю доступную версию Joomla! по соображениям безопасности. Старые версии Joomla! известны проблемами безопасности, которые активно используются для взлома сайтов.
  • Эта версия программного обеспечения имеет предварительную поддержку Joomla! 4 (протестирована только с Joomla! 4.0.0 Alpha 2), выпущенной в ноябре 2017 года. Обратите внимание, что Joomla! 4 все еще находится на ранней стадии развития. В результате нет никаких гарантий, что программное обеспечение будет работать без проблем в будущем тестировании или стабильных версиях Joomla! 4. Пожалуйста, имейте в виду, что, как и сама Joomla 4, тестирование, в настоящее время, продолжается.

ВНИМАНИЕ! Следующее семейство версий Akeeba Backup 6.1 больше не будет поддерживать Joomla! 3.4, 3.5 и 3.6.

Требуется PHP 5.4.0 или любая последующая версия 5.x/7.x. Поддержка PHP 5.3 была прекращена. Жизненный цикл PHP 5.3 был завершен, с августа 2014 года, версия повсеместно считается угрозой безопасности и непригодной для производственных площадок. Текущее программное обеспечение требует PHP 5.4 или новее и совместимо с PHP 5.4, 5.5, 5.6, 7.0, 7.1 и 7.2. Мы настоятельно рекомендуем использовать PHP 5.6 или 7.1.

Напомним, что Joomla! 3.4 НЕ поддерживает PHP 7. PHP 7 поддерживается только Joomla! 3.5.0 и более поздними версиями. Akeeba Backup будет работать отлично (и очень быстро!) На Joomla! 3.5 или более поздней версии сайта, работающего на PHP 7.0.

ВНИМАНИЕ! Следующее семейство версий Akeeba Backup 6.1 больше не будет поддерживать PHP 5.4 и 5.5.

Изменения

Исправление ошибок

  • [ВЫСОКИЙ] Ссылки, указывающие внешние ограничения open_basedir, вызывают PHP Fatal error, останавливая резервное копирование;
  • [НИЗКИЙ] Интерфейс Мастера Переноса Сайта работает беспорядочно;
  • [НИЗКИЙ] Мастер Переноса Сайта использует неправильные значения цветов;
  • [НИЗКИЙ] Ссылка на Журнал Логов, отображаемая после резервного копирования, повреждена, когда резервная копия завершается при загрузке одной страницы;
  • [СРЕДНИЙ] Разрешения на резервное копирование по умолчанию должны быть 0644, а не 0755;
  • [СРЕДНИЙ] Исправлено сканирование папки, когда файл недоступен из-за ограничений open_basedir;
  • [СРЕДНИЙ] Инсталлятор (ANGIE) не включал языковые файлы в резервную копию.

Новые возможности

  • Обновленный мастер переноса сайта, с дополнительными возможностями для улучшения совместимости с большим количеством серверов;
  • Поддержка класса хранения Amazon S3 OneZone-IA (однозонный, нечетный доступ)

Дата выхода: 22 мая 2018
Название: Akeeba Backup (версия 6.1.0 Stable для Joomla 3.4, 3.5, 3.6, 3.7, 3.8, 3.9, 4.0.0 Alpha 2)
Выпущено: Akeeba Backup [www.akeebabackup.com]
Локализация, правка и доработка, а также портирование: Joomlamaster.org.ua
Формат: *.zip (полностью готовый к установке компонент)
Язык интерфейса: Русский | Українська | English
Платформа: CMS Joomla 3.4, 3.5, 3.6, 3.7, 3.8, 3.9, 4.0.0 Alpha 2 (PHP5.4.0 и выше)
Лицензия: Бесплатно [GNU|GPL v.3.0]
Размер: 2,43 Mb
Имя файла: pkg_akeeba-6.1.0-core-uk-ru-en.zip
Хеш
MD5: 679388A8E9FD3CC581193DA6DF199507
SHA-1: 7490FCD17317796537CAE792839EB89E58F325CC

Скачать компонент резервного копирования Джумла 3.4+ - 4.0.0: AkeebaBackup 6.1.0

Разработано для Disqus